Back to overview
Web Service and Core Functions are down
Sep 26 at 03:49pm CAT
Resolved
Sep 26 at 03:49pm CAT
Migration for all accounts to a new server.
Affected services
Resolved
Sep 26 at 03:49pm CAT
Migration for all accounts to a new server.
Affected services