Back to overview
Downtime

Core Functions, POP3 Connection, SMTP Connection, IMAP Connection, and 2 other services are down

Aug 12 at 06:50pm CAT

Resolved
Aug 12 at 07:02pm CAT

Core Functions, POP3 Connection, SMTP Connection, and 1 other resource recovered.

Created
Aug 12 at 06:50pm CAT

Core Functions, POP3 Connection, SMTP Connection, and 1 other resource went down.